e2fsprogs-devel-1.41.12-3.el6.x86_64 has missing requires of e2fsprogs-libs = ('0', '1.41.12', '3.el6')


Enter Your Query:
Use '%' for wildcards and quotes for "exact phrases"


Top Level » DirectAdmin

e2fsprogs-devel-1.41.12-3.el6.x86_64 has missing requires of e2fsprogs-libs = ('0', '1.41.12', '3.el6')Last Modified: Jun 26, 2013, 11:57 am
During the yum pre-install command, if you're running into this error:

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
e2fsprogs-libs = 1.41.12-3.el6 is needed by (installed) e2fsprogs-devel-1.41.12-3.el6.x86_64
** Found 16 pre-existing rpmdb problem(s), 'yum check' output follows:
e2fsprogs-devel-1.41.12-3.el6.x86_64 has missing requires of e2fsprogs-libs = ('0', '1.41.12', '3.el6')
e2fsprogs-devel-1.41.12-3.el6.x86_64 has missing requires of libcom_err-devel
e2fsprogs-devel-1.41.12-3.el6.x86_64 has missing requires of pkgconfig(com_err)
krb5-devel-1.8.2-3.el6.x86_64 has missing requires of keyutils-libs-devel
krb5-devel-1.8.2-3.el6.x86_64 has missing requires of libcom_err-devel
krb5-devel-1.8.2-3.el6.x86_64 has missing requires of libselinux-devel
krb5-workstation-1.10.3-10.el6_4.3.x86_64 has missing requires of krb5-libs = ('0', '1.10.3', '10.el6_4.3')
krb5-workstation-1.10.3-10.el6_4.3.x86_64 has missing requires of libkadm5clnt_mit.so.8()(64bit)
krb5-workstation-1.10.3-10.el6_4.3.x86_64 has missing requires of libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)
krb5-workstation-1.10.3-10.el6_4.3.x86_64 has missing requires of libkadm5srv_mit.so.8()(64bit)
krb5-workstation-1.10.3-10.el6_4.3.x86_64 has missing requires of libkadm5srv_mit.so.8(kadm5srv_mit_8_MIT)(64bit)
krb5-workstation-1.10.3-10.el6_4.3.x86_64 has missing requires of libkdb5.so.6()(64bit)
krb5-workstation-1.10.3-10.el6_4.3.x86_64 has missing requires of libkdb5.so.6(kdb5_6_MIT)(64bit)
openssl-devel-1.0.0-4.el6.x86_64 has missing requires of zlib-devel
samba4-libs-4.0.0-55.el6.rc4.x86_64 has missing requires of krb5-libs >= ('0', '1.10', None)
sssd-1.9.2-82.7.el6_4.x86_64 has missing requires of krb5-libs(x86-64) >= ('0', '1.10', None)

you can run this first:

yum update e2fsprogs-libs e2fsprogs e2fsprogs-devel

and then run the pre-install command again.
 
Related Helpfiles
Common pre-install commands

© 2018 JBMC Software, Suite 173  3-11 Bellerose Drive, St Albert, AB  T8N 1P7  Canada.  Mon-Fri 9AM-5PM MST