/usr/local/lib/libz.so.1: no version information available (required by python)


Enter Your Query:
Use '%' for wildcards and quotes for "exact phrases"


Top Level » System Level

/usr/local/lib/libz.so.1: no version information available (required by python)Last Modified: Mar 29, 2012, 2:34 pm
If you see the error

/usr/local/lib/libz.so.1: no version information available (required by python)

it has to do with the version of libz installed.  The reason for the current version has to do with the version of libz that libxml2 requires.  A newer version of both will resolve the issue, but due to many reported issues with this update, we reverted to the older version of libz and libxml2.   Note that the warning is not going to hurt anything, so it can be ignored.

We do not recommend using the options below.

If you still wish to update libz and libxml2 to their newer versions to avoid the message, type:

cd /usr/local/directadmin/custombuild
./build update
./build set new_zlib yes
./build update_data
./build zlib
./build libxml2
./build php n


Related thread

2003 JBMC Software, Suite 173  3-11 Bellerose Drive, St Albert, AB  T8N 1P7  Canada.  Mon-Fri 9AM-5PM MST