/libexec/ld-elf.so.1: Shared object "libintl.so.9" not found, required by "gmake"


Enter Your Query:
Use '%' for wildcards and quotes for "exact phrases"


Top Level » CustomBuild

/libexec/ld-elf.so.1: Shared object "libintl.so.9" not found, required by "gmake"Last Modified: Apr 21, 2011, 1:54 am
On FreeBSD systems, gmake is required for a few of the modules (Freetype, in this example).
If it's missing, the custombuild script will attempt to install it with ports, and failing that, with pkg_add, eg:
If /usr/local/bin/gmake is missing, it will run:

cd /usr/ports/devel/gmake
               make
               make install
               make clean

if, after those commands, /usr/local/bin/gmake still doesn't exist, it will then run this as a last resort:

pkg_add -r gmake


There have been a few reports of the following error:

Configuring freetype-2.4.4...
GNU make (>= 3.80) or makepp (>= 1.19) is required to build FreeType2.
Please try
 `GNUMAKE=<GNU make command name> ./configure'.
or >&2
 `GNUMAKE="makepp --norc-substitution" ./configure'.
Done. Making freetype-2.4.4...
Trying to make FreeType...
/libexec/ld-elf.so.1: Shared object "libintl.so.9" not found, required by "gmake"

with the relevant error message in bold.

What the error means is that a required library is missing.
On some versions of freebsd, the libintl.so.9 might be missing, but the libintl.so.8 is there.
If that's the case, you can try using the command:

ln -s libintl.so.8 /usr/local/lib/libintl.so.9

to see if that repairs the "gmake" command.  (test running it to see if error goes away).

It will still be better to get a problem gmake binary for your OS, or get the newer libintl.so.9 library, but in many cases this is an quick and easy workaround.
 
Related Helpfiles
/libexec/ld-elf.so.1: Shared object "libintl.so.9" not found, required by "gmake"

2003 JBMC Software, Suite 173  3-11 Bellerose Drive, St Albert, AB  T8N 1P7  Canada.  Mon-Fri 9AM-5PM MST