sa-update: error: gpg required but not found!


Enter Your Query:
Use '%' for wildcards and quotes for "exact phrases"


Top Level » Email » Spam

sa-update: error: gpg required but not found!Last Modified: Jun 13, 2010, 7:44 pm
If you get the following error when trying to run sa-update:

[57535] dbg: gpg: Searching for 'gpg'
[57535] dbg: util: current PATH is: /sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin
error: gpg required but not found!

You'll need to install gnupg.  You can do this with your own systems package manager (apt-get, yum, pkg_add -r, etc), but if you need to install it from source, use the following:

wget ftp://ftp.gnupg.ca/gnupg/gnupg-2.0.15.tar.bz2
bunzip2 gnupg-2.0.15.tar.bz2
tar xvf gnupg-2.0.15.tar
cd gnupg-2.0.15
./configure && make && make install

The alternative is to simply not use gpg:

sa-update --nogpg





It may be the case that you're missing some required libraries to install gnupg.  Here are some of them:

libgpg-error:

wget ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-1.8.tar.gz
tar xvzf libgpg-error-1.8.tar.gz
cd libgpg-error-1.8
./configure && make && make install
cd ..


libgcrypt:

wget ftp://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-1.4.5.tar.gz
tar xvzf libgcrypt-1.4.5.tar.gz
cd libgcrypt-1.4.5
./configure
./configure && make && make install
cd ..


libassuan:

wget ftp://ftp.gnupg.org/gcrypt/libassuan/libassuan-2.0.0.tar.bz2
bunzip2 libassuan-2.0.0.tar.bz2
tar xvf libassuan-2.0.0.tar
cd libassuan-2.0.0
./configure && make && make install
cd ..


libksb:

wget ftp://ftp.gnupg.org/gcrypt/libksba/libksba-1.0.7.tar.bz2
bunzip2 libksba-1.0.7.tar.bz2
tar xvf libksba-1.0.7.tar
cd libksba-1.0.7
./configure && make && make install
cd ..


pth portable threads library:

wget ftp://ftp.gnu.org/gnu/pth/pth-2.0.7.tar.gz
tar xvzf pth-2.0.7.tar.gz
cd pth-2.0.7
./configure && make && make install
cd ..

© 2018 JBMC Software, Suite 173  3-11 Bellerose Drive, St Albert, AB  T8N 1P7  Canada.  Mon-Fri 9AM-5PM MST