How to install OpenLiteSpeed


Enter Your Query:
Use '%' for wildcards and quotes for "exact phrases"


Top Level » CustomBuild
Top Level » CustomBuild » CustomBuild 2.0 » OpenLiteSpeed

How to install OpenLiteSpeedLast Modified: Apr 23, 2019, 3:36 pm
OpenLiteSpeed is the Open Source edition of LiteSpeed Web Server Enterprise. OpenLiteSpeed contains all of the essential features found in LiteSpeed Enterprise, including LSCache (plugin needed for WordPress).

To install OpenLiteSpeed (DA 1.57 or higher is needed, it would run fine with pre-release binaries too):

1) You must have CustomBuild 2.0. If you do not, upgrade to CustomBuild 2.0
If unsure of which version of CustomBuild you're using, see this guide.

2) You can either run this in step 2 of the CB2 install guide, or do it after. Run the following to set the options.conf to use OpenLiteSpeed and lsphp:

./build set webserver openlitespeed
./build set php1_mode lsphp
./build openlitespeed
./build php n
./build rewrite_confs


If you have more than 1 php version, set php2_mode lsphp for all other php#_modes.

© 2018 JBMC Software, Suite 173  3-11 Bellerose Drive, St Albert, AB  T8N 1P7  Canada.  Mon-Fri 9AM-5PM MST