Wrong JPEG library version: library is 70, caller expects 62


Enter Your Query:
Use '%' for wildcards and quotes for "exact phrases"


Top Level » CustomBuild » ./build php

Wrong JPEG library version: library is 70, caller expects 62Last Modified: Feb 10, 2013, 11:34 pm
Issue reported for some 64-bit FreeBSD systems, where the following error appears in the apache logs:

Wrong JPEG library version: library is 70, caller expects 62



1) A reported solution was to install gd from ports and include it in php, instead of using the built-in gd library, eg:

/usr/ports/graphics/gd
setenv FORCE_PKG_REGISTER 1
make install
cd /usr/local/lib
ln -s /usr/local/include/gd*.h .


2) Then using this guide to change the line:

--with-gd

to be

--with-gd=/usr/local/lib

and recompile php.


Related thread:
http://www.directadmin.com/forum/showthread.php?t=33329&page=1



If you get the following error when recompiling php:

*** [libphp5.la] Error code 1
gcc: /usr/local/lib/libjpeg.so: No such file or directory

you could try:

./build libjpeg

but if that doesn't create the file/link:

/usr/local/lib/libjpeg.so

then try this instead:

cd /usr/ports/graphics/jpeg
make install

then recompile gd and php again.

2003 JBMC Software, Suite 173  3-11 Bellerose Drive, St Albert, AB  T8N 1P7  Canada.  Mon-Fri 9AM-5PM MST