Named is running, but it's not responding to requests


Enter Your Query:
Use '%' for wildcards and quotes for "exact phrases"


Top Level » DNS

Named is running, but it's not responding to requestsLast Modified: Nov 29, 2011, 4:20 pm
If named is running, your dns settings are correct (as far as you know), then the usual cause is either a firewall, or named.conf setting.

1) Ensure named is running and listening on all IPs:

netstat -lnp | grep named

You'll want to see all IPs listed, bound to port 53.  If not, check the  named.conf for a setting relating to the word "bind" or "listen" to ensure it's not just binding to local IPs.

2) Often, named will be bound to all IPs, but instructed to only offer responses to local IPs.  Check your named.conf and ensure this is not set:

allow-query     { localhost; };

as it will prevent external sources from querying your box.

3) We also don't want to see these lines, else named is only listening on these IPs, let alone which IPs it allows to query it.  Remove these if you find them:

listen-on port 53 { 127.0.0.1; };
listen-on-v6 port 53 { ::1; };


4) Ensure you don't have a firewall blocking port 53.  Shut off iptables to test:

/etc/init.d/iptables stop
/sbin/chkconfig iptables off


5) Test a query from an external server.  Using www.intodns.com tends to be the easiest way of doing that. It will also give you more info about your dns settings.

2003 JBMC Software, Suite 173  3-11 Bellerose Drive, St Albert, AB  T8N 1P7  Canada.  Mon-Fri 9AM-5PM MST